El libre pensamiento para un internet libre

No estas registrado.  

#1 Re: Herramientas wifi » Script multiuso wifi para Kali y otras distros » 01-04-2020 09:52:35

Sí que se puede... podrías cambiar la configuración del lighttpd para que actue en otro puerto.... pero ojo!!! eso es liarla muy parda, porque el portal cautivo se le va a abrir en el 80... así que también tendrías que cambiar las iptables para que la redirección sea al nuevo puerto que elijas.... y puede ser un poco lío.

Yo lo que te recomiendo es que esa otra aplicación o servicio que te ocupa el puerto 80 la cierres para hacer un ataque, hagas el ataque y luego si quirees cuando acabes la vuelves a abrir.... más sencillo, no???

También aprovecho desde aquí para recomendar a la gente que para hacer sus personalizaciones aprovechen y utilicen el sistema de plugins... que estoy un poco decepcionado la verdad. Hemos creado un sistema de plugins que es la hostia y no lo está usando ni cristo sad No se si es que a la gente le parecerá demasiado difícil o que es lo que ocurre.... pero os prometo que es una puta chorrada usarlo y que se pueden hacer muchas cosas...

Voy a resumir un poco de qué va:

airgeddon tiene un sistema de plugins que si tú metes un fichero .sh en la carpeta de plugins, te lo pilla automáticamente. Para crear un plugin teneis en esa carpeta una plantilla (el fichero plugin_template.sh) que solo hay que leer e ir rellenando. El sistema tiene tres formas de actuar sobre airgeddon... los prehooks, los override y los posthooks... ¿esto qué es? muy sencillo:

-los override "machacan" el contenido de una función de airgeddon para ejecutar el código que tú quieras programar en lugar de el código original en una función de airgeddon.

-los prehook ejecutan la mandanga que le pongas en tu función prehook justo antes de la función que has elegido.

-los posthook ejecutan tu código justo después de que se ejecute la función que hayas elegido.

Así que lo que hay que hacer para crear un plugin, es buscar en el código fuente el nombre de la función de airgeddon que se quiere modificar o personalizar. Para esto, mucho mejor que buscar directamente en el código fuente es activar en el fichero .airgeddonrc el modo de debug, que sería poniendo a "true" la variable AIRGEDDON_DEBUG_MODE y cuando se lance airgeddon, nos va a ir indicando por todas las funciones que pasa y como se llaman. Bien, cuando localicemos el sitio donde queremos tocar ya viendo el código fuente, decidimos como queremos modificar airgeddon...

En tu caso por ejemplo, se podría hacer un override de la función "set_webserver_config" copiando el contenido original y modificandolo con la personalización que en tu caso sería cambiarle el puerto del 80 al que quieras para que el server web lighttpd funcione en otro puerto, y luego tendrías también que modificar la función de las iptables haciéndole un override. Es la función set_std_internet_routing_rules, y copiar el contenido cambiando donde ponga 80 por tu otro puerto... no se si me dejo algo, lo he dicho así un poco de memoria. Y casi con toda seguridad la otra aplicación de tu puerto 80 no funcionará mientras el ataque Evil Twin está activo debido a las iptables que redirigirían el tráfico... por eso en tu caso concreto casi es mejor directamente hacer lo que comentaba al principio... parar ese servicio, lanzar Evil Twin y cuando acabes volverlo a lanzar... pero bueno, así aprovechaba un poco para que vierais como se haría un plugin.

Dejo unos links del wiki que hablan sobre esto:
https://github.com/v1s1t0r1sh3r3/airged … s%20System
https://github.com/v1s1t0r1sh3r3/airged … evelopment

Estoy deseando que llegue un día en el que alguien haga un plugin que me sorprenda...

#2 Re: Herramientas wifi » Script multiuso wifi para Kali y otras distros » 26-03-2020 17:09:24

Si, pero solo si haces el DoS pursuit mode... en la ventana principal (ninguna de las 6 sino en la ventana madre de todas), ahí te dice que se ha detectado un cambio de canal, incluso te indica el nuevo canal cual es y todo. Además de que automáticamente matará la ventana de DoS y la relanzará en el nuevo canal "persiguiendo" al AP aunque se reinicie y cambie de canal... de ahí el nombre de DoS pursuit mode.

Saludos!

#3 Re: Herramientas wifi » Script multiuso wifi para Kali y otras distros » 26-03-2020 08:23:48

@Kcdtv, le explicaba que el txt se rompe con hashcat porque es la funcionalidad implementada para hacerlo dentro de airgeddon. Efectivamente fuera de airgeddon hay otras formas, con la opción -I de aircrack disponible a partir de cierta versión de aircrack o como indicaban por aquí también con john the ripper y puede que haya más métodos.

@Hunter310# , el portal cautivo se lanza sobre el canal del punto de acceso objetivo. Si este está en un canal fijo aunque reinicie el router le seguirá afectando. Si el canal lo tiene configurado en "auto", efectivamente al reiniciar, el punto de acceso del router cambiará de canal y el ataque DoS dejará de afectarle. Para "combatir" eso se creó el "DoS Pursuit Mode" en el que con un interfaz secundario se monitoriza el router para que si esto ocurre airgeddon sea capaz de darse cuenta del cambio de canal del router y así relanzar el DoS de nuevo en el nuevo canal, así que es la solución a tu problema número 1.

Respecto al problema número 2 que planteas, efectivamente airgeddon está hecho para que al salir, si le indicamos que queremos recuperar el modo de la tarjeta solo lo haga en la tarjeta principal, y la tarjeta secundaria no se ve afectada por estos cambios. Para que esto se pudiera hacer habría que llevar registro de como estaba inicialmente la tarjeta secundaria, guardar en alguna variable si hubo cambio y luego preguntar en la salida en otra pregunta aparte si queremos restaurar la tarjeta adicional y en caso de respuesta positiva realizar la misma operación. Algo muy trabajoso y que llevaría mucho tiempo para hacerlo cuando el beneficio es muy pequeño ya que casi nadie utiliza el "DoS pursuit mode" ya que no mucha gente tiene una tarjeta secundaria. No obstante, volver a cambiar el modo desde fuera de airgeddon es un simple comando "airmon-ng wlan1mon stop" <- cambiando wlan1mon por el nombre que tenga la tarjeta secundaria en ese momento.

#4 Re: Herramientas wifi » Script multiuso wifi para Kali y otras distros » 24-03-2020 20:56:29

Hola, acabo de sacar la versión v10.11 ya que algunas distros tienen una versión muy avanzada de hcxdumptool y al parecer los parámetros de la línea de comandos cambian. Ahora la nueva versión de airgeddon mira que versión de hcxdumptool tienes y crea la línea de comando con los parámetros necesarios para cada versión evitando errores.

Además también se han hecho modificaciones para mientras se captura un handshake, si por casualidad se captura un pmkid airgeddon lo detecte y lo de por bueno avisándonos. Todo ello validado por supuesto ya que pmkid en aircrack (airodump) solo en versiones >=1.4. También he integrado los pmkid para que se puedan usar en el evil twin captive portal opcionalmente al handshake.

@Hunter310# cuando capturas un pmkid y airgeddon te saca un fichero txt, es para que luego lo crackees utilizando hashcat. Puedes hacerlo desde el menú de descifrado offline en el submenú "Personal".

Respecto a la otra duda que tienes de los Evil Twin... no entendí un carajo big_smile lo siento. Me lo he leído 3 veces y es un lío tremendo lo que tienes ahí...

Saludos terrícolas! cool

#5 Re: Herramientas wifi » Script multiuso wifi para Kali y otras distros » 19-03-2020 13:09:16

Dicho y hecho. Acaba de salir la versión v10.10 con soporte PMKID. Saludos a [email protected]!!

#6 Re: Herramientas wifi » Script multiuso wifi para Kali y otras distros » 09-02-2020 22:38:19

Vamos a implementar la mandanga de PMKID para la próxima versión. Más vale tarde que nunca

#7 Re: Herramientas wifi » Script multiuso wifi para Kali y otras distros » 17-01-2020 19:52:57

Como bien dice kcdtv, no tiene que ver con airgeddon. Es un tema del driver de tu tarjeta. No especificas tu tarjeta ni versiones ni nada, pero parece obvio por el error (que es conocido) que tienes chipset Realtek. Si lo pruebas fuera de airgeddon obtendrás el mismo resultado. En ese hilo igual te pueden ayudar más.

#8 Re: Herramientas wifi » Script multiuso wifi para Kali y otras distros » 08-01-2020 10:10:25

Hola, hoy ha salido airgeddon v10.01 con algunos pequeños cambios, fixes y sobre todo ya sin las dependencias de net-tools y wireless-tools ya que ha dejado de utilizar ifconfig/iwconfig

También en la v10.01 ya funcionan las tarjetas con chipset Realtek sin necesidad del plugin que se generó para la v10.0 ya que los problemas venían del uso de iwconfig y su diferente salida. Ahora eso ya no afecta y funcionan bien sin plugin.

Saludos.

#9 Re: Herramientas wifi » Script multiuso wifi para Kali y otras distros » 02-01-2020 11:46:31

El script comprueba que el handshake está efectivamente contenido dentro del fichero capturado. Y lo comprueba con el propio aircrack que es más que suficiente para hacer dicha comprobación.

#10 Re: Herramientas wifi » Script multiuso wifi para Kali y otras distros » 21-12-2019 17:37:21

Hola, es muy posible que en 2020 implementemos PMKID.

Por otra parte, la v10.01 está ya apuntito y saldrá a primeros de año. Actualmente está en la rama dev de github y ya está bastante probada y funciona muy bien. Esta versión ya no usa ni ifconfig ni iwconfig.

Saludos.

#11 Re: Herramientas wifi » Script multiuso wifi para Kali y otras distros » 17-11-2019 13:01:53

Sí, a ver si la gente se anima a hacer plugins. Aquí está el primero además del que ya viene incluído en el propio airgeddon que es un auto instalador de las dependencias para Kali, Parrot, BlackArch. Este en cambio, es un plugin para compatibilizar las tarjetas que tienen chipset Realtek RTL88, lo que incluye a las conocidas RTL8812AU y RTL8814AU por el momento. Como sabéis, estas tarjetas son un poco "especiales" porque el driver se comporta de manera diferente al resto. Esto afecta a airgeddon porque la salida de los comandos (iwconfig, airmon, etc) es distinta con estas tarjetas y por lo tanto no funcionan con airgeddon. Ahora con este plugin se realizan los cambios necesarios para que las salidas se parseen de la forma especial que estas tarjetas necesitan y hace que sean compatibles con airgeddon:

https://github.com/OscarAkaElvis/airged … pset_fixer

Con este plugin ya se solucionan los problemas básicos y ya se pueden seleccionar, cambiar de modo, escanear y realizar operaciones básicas. No obstante, el plugin de airgeddon no hace "magia" y los problemas que tiene el driver siguen existiendo por lo que no se puede usar la parte de WPS y cuando se realiza un Evil Twin (que ya sabéis que el interfaz se desdobla en dos, uno para el AP y otro para DoS), resulta que el AP se crea bien, pero el DoS no funciona porque el driver no soporta bien la virtualización. Es decir, que el DoS de forma normal sí funciona, es solo cuando se desdobla la tarjeta, algo que en airgeddon solo pasa en los Evil Twin. Bueno, pues eso es cosa del driver y sigue fallando. Aún así es un gran avance.

Aprovecho también para ver si alguien me puede ayudar. Estoy planeando en la próxima versión de airgeddon v10.01 quitar completamente los comandos ifconfig y iwconfig que como sabéis están "deprecated". Estoy sustituyendo los mismos por comandos ip y comandos iw. Hasta aquí ok, pero tengo un problema que no se aún como resolver. Necesito algún método para detectar si una tarjeta es compatible con airmon-ng o no. Antes hacía un comando "iwconfig wlan0 rate 1M" y basándome en el código de salida me bastaba. No es que sea la mejor manera y espero que haya otras mejores y más sólidas (y si puede ser sin usar iwconfig). ¿Alguna sugerencia? Gracias.

#12 Re: Herramientas wifi » Script multiuso wifi para Kali y otras distros » 04-11-2019 16:18:19

Dicho y hecho!! la nueva versión de airgeddon v10.0 con el sistema de plugins (y otros features) ha visto la luz!!!

Changelog:

v10.0
- Added plugins system
- Added example plugin: Missing dependencies auto-installation for some distros (Kali, Parrot, BlackArch)
- Improvements for Evil Twin on captive portal detection for newer devices
- Missing 5GHz channels added
- Github pull request template added and issue templates updated
- Fixed error on hex2ascii conversion for some WEP passwords

Ahora la gente podrá desarrollar sus propias modificaciones de airgeddon sin apenas despeinarse... gracias al sistema de hooking de funciones que hemos creado (prehook, override y posthook), podemos elegir la función de airgeddon que actúe sobre la parte que queremos cambiar y de forma sencilla hacer las modificaciones oportunas. Más info aquí en estos links:
https://github.com/v1s1t0r1sh3r3/airged … s%20System
https://github.com/v1s1t0r1sh3r3/airged … evelopment

Además se ha creado una sección nueva en el Wiki "Plugins Hall of Fame" https://github.com/v1s1t0r1sh3r3/airged … 0of%20Fame donde pondremos enlaces externos a los plugins que haga la gente y que tengan cierta calidad.

No sabemos que repercusión tendrá esto... si luego no desarrollará plugins ni dios o si va a ser un pelotazo. En cualquier caso hemos disfrutado haciéndolo y creemos que es uno de esos features que pueden marcar la diferencia porque abren muchísimo las posibilidades para la comunidad.

Saludos!

#13 Re: Herramientas wifi » Script multiuso wifi para Kali y otras distros » 06-10-2019 19:16:06

Buenas, en airgeddon estamos liando una buena para la próxima versión. Estamos creando un sistema de plugins! para que la gente pueda hacer sus propias personalizaciones del script. Es ambicioso, pero si lo conseguimos puede ser la leche! dejo por aquí un link que explica todo lo que estamos haciendo y en qué consiste con más detalles: https://github.com/v1s1t0r1sh3r3/airgeddon/issues/308

Aprovecho para decir que hemos creado un canal de Discord para resolver dudas y ayudar a los usuarios (eso si, es un canal en el que se habla en inglés, sorry  >:D ). Dejo por aquí el link público de invitación: https://discord.gg/sQ9dgt9

Saludos!

#14 Re: Herramientas wifi » Script multiuso wifi para Kali y otras distros » 27-09-2019 07:07:04

v9.23 released . Esta no tiene grandes cambios, solo algunos fixes pequeños.

No quiero hacer mucho spoiler aún... pero estamos ya trabajando en la versión 10 que tendrá una mejora sustancial. Estamos intentando crear un sistema de plugins para que luego la gente pueda desarrollar pequeños módulos y realizar personalizaciones de airgeddon. Ya daré más detalles cuando esté más maduro.

Saludos!

#16 Re: Herramientas wifi » Script multiuso wifi para Kali y otras distros » 12-08-2019 22:10:06

Hola, hoy ha salido la nueva versión v9.21 de airgeddon con posibilidad de crear certificados personalizados para los ataques enterprise, retro-compatibilidad con mdk3 (se puede elegir si usar mdk4 o mdk3) y varios fixes. Saludos!

#17 Re: Herramientas wifi » Script multiuso wifi para Kali y otras distros » 25-05-2019 21:49:21

La versión 9.20 con tmux como alternativa a xterm ha visto la luz hoy al fin, ya está en la rama master. También tiene implementado el WPS null pin attack. Siento haber tardado en implementar esto, que ya tiene su tiempo, pero hasta hace poco no cayó en mis manos un AP vulnerable para poderlo probar.

Happy hacking!

#18 Re: Herramientas wifi » Script multiuso wifi para Kali y otras distros » 16-04-2019 22:58:31

Aun no ha llegado a master. la última publicada es la 9.11 . Lo de tmux es la 9.20 pero es que acabo de hacer el merge del branch headless_tmux (que acabo de borrar ya) a la rama dev. Así que si quieres probarla clona dicha rama así: git clone -b dev https://github.com/v1s1t0r1sh3r3/airgeddon

También acabo de implementar en esta versión 9.20 el ataque WPS Null PIN. Se que llega algo tarde pero es que hasta ahora no había tenido oportunidad de tener un punto de acceso vulnerable para probarlo, así que más vale tarde que nunca. Ha sido añadido al menú de WPS con reaver. Los de bully no parecen muy por la labor de actualizar nada. Tienen un issue abierto en el github justo para ese tema... parece que a uno de los autores le ocurre lo que me pasaba a mi, que no tenía un punto de acceso vulnerable para implementarlo. Me he ofrecido a hacer de beta tester por si lo quieren implementar ya que eso creo que sería muy sencillo... pero no parece que me vayan a hacer mucho caso, así que de momento el WPS Null pin attack solo con reaver: https://github.com/aanarchyy/bully/issues/14

Saludos.

#19 Re: Herramientas wifi » Script multiuso wifi para Kali y otras distros » 12-04-2019 21:30:37

Hola terrícolas,

Acaba de salir airgeddon v9.11 que corrige el tema ese de que al actualizarse salgan warnings por opciones no existentes en el fichero de opciones... bueno a ver, la validación sigue existiendo por si tocando te cargas algo del fichero pero ahora cuando se actualiza también se baja dicho fichero para incorporar posibles nuevas opciones. Además te respeta las personalizaciones que tuvieras para que no pierdas los posibles cambios que tuvieras al actualizarse.

También incluye modificaciones para la compatibilidad con BeEF ya que parece ser que habían hecho algunos cambios en el fichero de configuración y en algunas versiones no funcionaba bien. Ahora airgeddon detecta la versión de BeEF y prepara el fichero con los cambios necesarios para todas sus versiones incluyendo la que sacarán en breve 0.4.7.2.

He de decir que la futura versión v9.20 con soporte para tmux está ya muy avanzada. De hecho lo de tmux está terminado y en beta testing... si algún valiente se atreve ya sabe... que se descargue el branch "headless_tmux" del repo y que lo pruebe. Con este cambio se podría lanzar airgeddon en Linux que no tengan entorno gráfico. Para ponerlo en alguna Raspberry Pi antigua o similar que va muy justa de recursos, puede venir muy bien ponerla en modo "headless" (sin entorno gráfico) y así poder lanzar la herramienta. La verdad es que ha sido un esfuerzo titánico... ha habido que reestructurar algunas cosas... pero creo que ha merecido la pena. Igual en un mes o así podréis disfrutar de esta versión.

Saludos terrícolas!

#20 Re: Herramientas wifi » Script multiuso wifi para Kali y otras distros » 30-03-2019 13:10:56

Vale, acabamos de sacar la version 9.10 . mdk3 ha sido reemplazado por mdk4 y ahora también tiene soporte para nftables.

Estamos trabajando duro en la 9.20 que incluirá soporte tmux para evitar necesitar servidor X (es configurable en el nuevo sistema de opciones del fichero .airgedodnrc). En algunos entornos puede ser interesante.

Saludos!

#21 Re: Herramientas wifi » Script multiuso wifi para Kali y otras distros » 20-02-2019 13:02:07

Puse un issue en busca de ayuda. A ver si alguien me echa un cable: https://github.com/v1s1t0r1sh3r3/airgeddon/issues/224

Si averiguo algo te aviso Koala. Gracias.

#22 Re: Herramientas wifi » Script multiuso wifi para Kali y otras distros » 14-02-2019 22:04:18

Hola, tras la release de la v9.01 , ahora estamos trabajando en la 9.10 . En esta versión ya hemos cambiado mdk3 por mdk4 y alguna cosilla más... y voy a necesitar la ayuda de los grandes maestros del wifi! para la parte de ataques enterprise. Estoy intentando implementar el ataque downgrade dumb-down para enterprise.
Hasta ahora con airgeddon en los ataques enterprise, cuando el cliente conecta a la red enterprise falsa con la configuración por defecto, capturamos hashes que luego se puede intentar romper... si el cliente configura (se puede probar con cualquier cliente android mismamente) TTLS / PAP , las credenciales aparecen en plano. Hasta aquí bien, porque airgeddon ya gestiona todo esto de capturar o bien hashes o bien credenciales, o ambos. Digamos que si el cliente hace esto es que lo está haciendo mal... está utilizando una configuración insegura.

Bien, el ataque Dumb-Down se supone que trata de "engañar" al cliente para que aunque lo tenga bien configurado, obligarle a usar esa autenticación insegura y así poder capturar las credenciales en texto plano.

He estado investigando y he visto este artículo muy interesante: https://www.securityartwork.es/2014/01/ … esariales/

Tengo entendido que para que esto funcione, también dependerá del cliente. Es decir, que no se va a poder engañar a todos los clientes para que hagan la autenticación en el modo inseguro... por lo que pone en el artículo esto ya es algo antiguo (2013 aprox)... y claro, desde ese artículo q es de 2014 pues ya ha llovido... el caso es que no consigo hacerlo funcionar y no se si es que lo estoy haciendo mal o bien es que los clientes de hoy en día ya no son vulnerables a esto. Estoy probando con un cliente android 8 y con un cliente android 6 algo más antiguo... pero claro, en el artículo pone que los iOS 5, 6 y 7 son vulnerables pero no especifica versión de android. No se si en esa época igual estaba android 4, y me va a costar encontrar un android 4 (o montar alguna historia virtual) para poder probar esto. Estoy haciendo pruebas con freeradius-wpe intentando llevarlo a cabo pero no hay manera. En el artículo solo se ve un pantallazo de la configuracion del freeradius y me estoy basando un poco en eso porque apenas encuentro información.

Mis preguntas son...
¿Alguien ha hecho funcionar dumb-down alguna vez? si es así, ¿me puede pasar un fichero de configuración de freeradius o freeradius-wpe que funcione? ¿con qué cliente lo hizo funcionar?
¿alguien tiene algún artículo o algo de info donde indiquen la configuración del freeradius?
Si ya no funciona con clientes modernos... ¿merece la pena implementarlo?

Gracias!!!

#23 Re: Herramientas wifi » Script multiuso wifi para Kali y otras distros » 31-01-2019 22:09:46

Sí, haces un día un "apt update && apt dist-upgrade" y descubres que han cambiado algunas cosas y no funcionan. Es lo que tiene usar herramientas de terceros, que tienes que ir todo el día "al rebufo" arreglando y adaptando los cambios que van implementando. En el caso de las iptables, @javierbu puedes comprobar si cuando ejecutas un simple comando "iptables" te aparece entre paréntesis (nftables). Si es así, es que tu versión de iptables ya es la nueva. También notarás que además del comando iptables tienes "iptables-legacy" que es el de siempre y el que has de usar si quieres seguir usando la nomenclatura que conoces.

Bueno, ya está el fix para que funcione siempre. Como dice @kcdtv, ahora ya con calma y sin prisa podemos hacer que airgeddon detecte que version tienes y hacerlo como proceda. Para ello habrá que adaptar las reglas a la nueva sintaxis, que todavía ni me he molestado en mirar como funciona, ya lo haré.

Otro ejemplo de tools que evolucionan y que no nos da tiempo a encagar es Bettercap. Estamos ahora "peleando" para integrar bettercap 2.x . Como sabéis, en airgeddon hay un ataque Evil Twin integrado con bettercap y BeEF. El tema es que la última versión de bettercap que soporta airgeddon (por ahora) es la 1.62. Es decir, la última antes del gran cambio. La nueva versión es otro mundo. Antes estaba desarrollada en ruby y ahora es go. Ahora no se puede lanzar un comando con todos los parámetros como antes. Ahora hay que crear un fichero de configuración "caplet" y al lanzar bettercap sale una consola interactiva. Vamos, que no tiene nada que ver y estamos estudiando como funciona y haciendo pruebas para intentar ponerlo en marcha. Incluso tenemos un branch donde estamos haciendo pruebas y commits para integrarlo. Por ahora seguirá como está, y si detecta que tu bettercap es una versión 2.x (que no está soportada) pues airgeddon te indica que la última soportada es la 1.6.2 y te sugiere que hagas un downgrade. Además te indica un link al wiki donde te explican como hacer el downgrade de una manera sencilla. (https://github.com/v1s1t0r1sh3r3/airged … cap%20Tips)

Además, mientras intentamos integrar las herramientas, descubrimos bugs y problemas que siempre solemos reportar. Y normalmente son cosas razonables y se solucionan. Se han reportado cosas en Bettercap, BeEF, reaver, bully, etc. Así que ponemos también nuestro granito de arena con la comunidad ayudando a las herramientas de terceros que usamos. El ejemplo de ahora con bettercap: https://github.com/bettercap/bettercap/issues/428

Bueno, ya os iré informando si hay novedades, aunque ahora mismo necesito unas vacaciones de programar que estoy un poco saturado! Saludos!

#24 Re: Herramientas wifi » Script multiuso wifi para Kali y otras distros » 31-01-2019 13:04:18

Uff... ha habido q sacar una v9.01 así un poco de emergencia... no estaban rulando los Evil Twin en algunos linux... cortesía del último update de iptables. Al parecer en los linux muy modernos ya están las nftables pero q usan el mismo comando iptables y las viejas iptables han quedado relegadas al comando iptables-legacy .

Supuestamente esto de las nftables será la leche y tal... uniendo arptables e iptables y algunas cosillas mas... pero bueno, el caso es q he tenido q hacer un fix para q detecte en tu sistema si ya tienes unas nftables y si es así, q use las iptables-legacy (q son las de siempre) y si no tienes iptables-legacy es q tus iptables son las normales todavía porq no actualizaste.... un puto lío vamos, pero q ya funciona en todas partes con el fix q hicimos en la v9.01. No obstante, tengo claro que en un futuro no muy lejano tendré q portar las reglas al nuevo formato de las nftables, eso seguro, aunque de momento con el fix funciona todo en todas partes así que no hay prisa.

Bueno, también tiene alguna chorradita más por ahi esta versión... alguna mejora para arm y poco mas.

Saludos!

#25 Re: Herramientas wifi » Script multiuso wifi para Kali y otras distros » 29-01-2019 16:58:28

Ale, por fin... ya está released la v9.0 de airgeddon. Se ha hecho de rogar pero es que era una release muy gorda con muchos cambios.... "para vosotros jugadores", a disfrutar!!! lol

Pie de página

Información del usuario

Ultimo usuario registrado: jcspto
Usuarios registrados conectados: 0
Invitados conectados: 26

Estadisticas de los foros

Número total de usuarios registrados: 1,813
Número total de temas: 1,389
Número total de mensajes: 13,921

Máx. usuarios conectados: 373 el 30-09-2019 15:04:36
Impulsado por FluxBB