El libre pensamiento para un internet libre

No estas registrado.  

Anuncio

Wifi-highpower.es es distribuidor oficial de Alfa Network

#51 01-09-2018 14:50:41

crash
Expulsado

Registrado: 25-10-2017
Mensajes: 1,049

Re: Linux tan difícil de instalar AMD GPU

tienes que cambiar false por true y ctrl+s
y luego hacer una prueba con  pyrit benchmark o list cores.

¿has instalado el controlador amd en kali?

Desconectado

Anuncio

Wifi-libre.com: El libre pensamiento para un internet libre / Regístrese ahora

#52 01-09-2018 16:14:52

bala
Usuario

Registrado: 26-07-2017
Mensajes: 110

Re: Linux tan difícil de instalar AMD GPU

Creo que mi controlador de gpu está bien ahora.
lo hice de nuevo https://github.com/AS4SR/general_info/w … for-VR-use
Instalación completa
porque. saco HD7970 mismo lugar RX vega puse. ahora mi icono de pantalla es normal.


solo en blanco escribo manualmente no puede guardar ctrl + s un masaje


https://imgur.com/a/i2GDjZt

Ultima edición por bala (01-09-2018 16:29:36)

Desconectado

#53 02-09-2018 06:25:11

crash
Expulsado

Registrado: 25-10-2017
Mensajes: 1,049

Re: Linux tan difícil de instalar AMD GPU

tienes que darle permisos de administrador con sudo.
porque estas en el directorio root.

para /root/.pyrit/config

sudo gedit /root/.pyrit/config

para usuario bala

gedit /home/bala/.pyrit/config

cambia false por true y ctrl+s para guardar los cambios

Desconectado

#54 02-09-2018 10:27:48

bala
Usuario

Registrado: 26-07-2017
Mensajes: 110

Re: Linux tan difícil de instalar AMD GPU

Gracias..
yo cambio use OpenCL = verdadero.
pero igual tanto OS kali como Ubuntu check Picture.
una cosa más, hashcat tampoco puede ver la GPU



[email protected]:~$ hashcat -m 2500 -b
hashcat (v4.2.1) starting in benchmark mode...

Benchmarking uses hand-optimized kernel code by default.
You can use it in your cracking session by setting the -O option.
Note: Using optimized kernel code limits the maximum supported password length.
To disable the optimized kernel code in benchmark mode, use the -w option.

clGetPlatformIDs(): CL_PLATFORM_NOT_FOUND_KHR

Started: Sun Sep  2 05:38:03 2018
Stopped: Sun Sep  2 05:38:03 2018

https://imgur.com/a/642ic79

https://imgur.com/a/dA1hrYd

Ultima edición por bala (02-09-2018 10:39:42)

Desconectado

#55 03-09-2018 04:14:45

crash
Expulsado

Registrado: 25-10-2017
Mensajes: 1,049

Re: Linux tan difícil de instalar AMD GPU

¿tienes esto instalado?

clinfo-amdgpu-pro 
opencl-amdgpu-pro-icd 
amdgpu-pro-dkms 
libdrm2-amdgpu-pro 
libdrm-amdgpu-pro-amdgpu1

si no está instalado... debes de instalarlo.

mismo comando para ubuntu y kali

sudo amdgpu-pro-install --compute

Desconectado

#56 04-09-2018 05:03:59

bala
Usuario

Registrado: 26-07-2017
Mensajes: 110

Re: Linux tan difícil de instalar AMD GPU

Desconectado

#57 04-09-2018 05:48:03

crash
Expulsado

Registrado: 25-10-2017
Mensajes: 1,049

Re: Linux tan difícil de instalar AMD GPU

bala estoy un poco harto de que no hagas lo que se te dice, no te dicho que hagas -y
si no, que pongas --compute, para cuatro comandos llevamos ya 57 mensajes.

Desconectado

#58 04-09-2018 05:55:53

bala
Usuario

Registrado: 26-07-2017
Mensajes: 110

Re: Linux tan difícil de instalar AMD GPU

[email protected]:~$ cd amdgpu-pro-18.30-641594
[email protected]:~/amdgpu-pro-18.30-641594$ ls
amdgpu_18.30-641594_amd64.deb
amdgpu_18.30-641594_i386.deb
amdgpu-core_18.30-641594_all.deb
amdgpu-dkms_18.30-641594_all.deb
amdgpu-doc_18.30-641594_all.deb
amdgpu-install
amdgpu-lib32_18.30-641594_amd64.deb
amdgpu-pro_18.30-641594_amd64.deb
amdgpu-pro_18.30-641594_i386.deb
amdgpu-pro-core_18.30-641594_all.deb
amdgpu-pro-install
amdgpu-pro-lib32_18.30-641594_amd64.deb
amf-amdgpu-pro_1.4.9-641594_amd64.deb
clinfo-amdgpu-pro_18.30-641594_amd64.deb
clinfo-amdgpu-pro_18.30-641594_i386.deb
doc
glamor-amdgpu_1.19.0-641594_amd64.deb
glamor-amdgpu_1.19.0-641594_i386.deb
glamor-amdgpu-dev_1.19.0-641594_amd64.deb
glamor-amdgpu-dev_1.19.0-641594_i386.deb
gst-omx-amdgpu_1.0.0.1-641594_amd64.deb
gst-omx-amdgpu_1.0.0.1-641594_i386.deb
libdrm2-amdgpu_2.4.92-641594_amd64.deb
libdrm2-amdgpu_2.4.92-641594_i386.deb
libdrm-amdgpu-amdgpu1_2.4.92-641594_amd64.deb
libdrm-amdgpu-amdgpu1_2.4.92-641594_i386.deb
libdrm-amdgpu-common_1.0.0-641594_all.deb
libdrm-amdgpu-dev_2.4.92-641594_amd64.deb
libdrm-amdgpu-dev_2.4.92-641594_i386.deb
libdrm-amdgpu-radeon1_2.4.92-641594_amd64.deb
libdrm-amdgpu-radeon1_2.4.92-641594_i386.deb
libdrm-amdgpu-utils_2.4.92-641594_amd64.deb
libdrm-amdgpu-utils_2.4.92-641594_i386.deb
libegl1-amdgpu-mesa_18.1.0-641594_amd64.deb
libegl1-amdgpu-mesa_18.1.0-641594_i386.deb
libegl1-amdgpu-mesa-dev_18.1.0-641594_amd64.deb
libegl1-amdgpu-mesa-dev_18.1.0-641594_i386.deb
libegl1-amdgpu-mesa-drivers_18.1.0-641594_amd64.deb
libegl1-amdgpu-mesa-drivers_18.1.0-641594_i386.deb
libegl1-amdgpu-pro_18.30-641594_amd64.deb
libegl1-amdgpu-pro_18.30-641594_i386.deb
libgbm1-amdgpu_18.1.0-641594_amd64.deb
libgbm1-amdgpu_18.1.0-641594_i386.deb
libgbm1-amdgpu-pro_18.30-641594_amd64.deb
libgbm1-amdgpu-pro_18.30-641594_i386.deb
libgbm1-amdgpu-pro-base_18.30-641594_all.deb
libgbm1-amdgpu-pro-dev_18.30-641594_amd64.deb
libgbm1-amdgpu-pro-dev_18.30-641594_i386.deb
libgbm-amdgpu-dev_18.1.0-641594_amd64.deb
libgbm-amdgpu-dev_18.1.0-641594_i386.deb
libgl1-amdgpu-mesa-dev_18.1.0-641594_amd64.deb
libgl1-amdgpu-mesa-dev_18.1.0-641594_i386.deb
libgl1-amdgpu-mesa-dri_18.1.0-641594_amd64.deb
libgl1-amdgpu-mesa-dri_18.1.0-641594_i386.deb
libgl1-amdgpu-mesa-glx_18.1.0-641594_amd64.deb
libgl1-amdgpu-mesa-glx_18.1.0-641594_i386.deb
libgl1-amdgpu-pro-appprofiles_18.30-641594_all.deb
libgl1-amdgpu-pro-dri_18.30-641594_amd64.deb
libgl1-amdgpu-pro-dri_18.30-641594_i386.deb
libgl1-amdgpu-pro-ext_18.30-641594_amd64.deb
libgl1-amdgpu-pro-ext_18.30-641594_i386.deb
libgl1-amdgpu-pro-glx_18.30-641594_amd64.deb
libgl1-amdgpu-pro-glx_18.30-641594_i386.deb
libglapi-amdgpu-mesa_18.1.0-641594_amd64.deb
libglapi-amdgpu-mesa_18.1.0-641594_i386.deb
libgles1-amdgpu-mesa_18.1.0-641594_amd64.deb
libgles1-amdgpu-mesa_18.1.0-641594_i386.deb
libgles1-amdgpu-mesa-dev_18.1.0-641594_amd64.deb
libgles1-amdgpu-mesa-dev_18.1.0-641594_i386.deb
libgles2-amdgpu-mesa_18.1.0-641594_amd64.deb
libgles2-amdgpu-mesa_18.1.0-641594_i386.deb
libgles2-amdgpu-mesa-dev_18.1.0-641594_amd64.deb
libgles2-amdgpu-mesa-dev_18.1.0-641594_i386.deb
libgles2-amdgpu-pro_18.30-641594_amd64.deb
libgles2-amdgpu-pro_18.30-641594_i386.deb
libllvm6.0-amdgpu_6.0-641594_amd64.deb
libllvm6.0-amdgpu_6.0-641594_i386.deb
libopencl1-amdgpu-pro_18.30-641594_amd64.deb
libopencl1-amdgpu-pro_18.30-641594_i386.deb
libosmesa6-amdgpu_18.1.0-641594_amd64.deb
libosmesa6-amdgpu_18.1.0-641594_i386.deb
libosmesa6-amdgpu-dev_18.1.0-641594_amd64.deb
libosmesa6-amdgpu-dev_18.1.0-641594_i386.deb
libwayland-amdgpu-client0_1.14.0-641594_amd64.deb
libwayland-amdgpu-client0_1.14.0-641594_i386.deb
libwayland-amdgpu-cursor0_1.14.0-641594_amd64.deb
libwayland-amdgpu-cursor0_1.14.0-641594_i386.deb
libwayland-amdgpu-dev_1.14.0-641594_amd64.deb
libwayland-amdgpu-dev_1.14.0-641594_i386.deb
libwayland-amdgpu-doc_1.14.0-641594_all.deb
libwayland-amdgpu-egl1-mesa_18.1.0-641594_amd64.deb
libwayland-amdgpu-egl1-mesa_18.1.0-641594_i386.deb
libwayland-amdgpu-server0_1.14.0-641594_amd64.deb
libwayland-amdgpu-server0_1.14.0-641594_i386.deb
libxatracker2-amdgpu_18.1.0-641594_amd64.deb
libxatracker2-amdgpu_18.1.0-641594_i386.deb
libxatracker-amdgpu-dev_18.1.0-641594_amd64.deb
libxatracker-amdgpu-dev_18.1.0-641594_i386.deb
llvm-amdgpu-6.0_6.0-641594_amd64.deb
llvm-amdgpu-6.0_6.0-641594_i386.deb
llvm-amdgpu_6.0-641594_amd64.deb
llvm-amdgpu_6.0-641594_i386.deb
llvm-amdgpu-6.0-dev_6.0-641594_amd64.deb
llvm-amdgpu-6.0-dev_6.0-641594_i386.deb
llvm-amdgpu-6.0-doc_6.0-641594_all.deb
llvm-amdgpu-6.0-runtime_6.0-641594_amd64.deb
llvm-amdgpu-6.0-runtime_6.0-641594_i386.deb
llvm-amdgpu-dev_6.0-641594_amd64.deb
llvm-amdgpu-dev_6.0-641594_i386.deb
llvm-amdgpu-runtime_6.0-641594_amd64.deb
llvm-amdgpu-runtime_6.0-641594_i386.deb
mesa-amdgpu-common-dev_18.1.0-641594_amd64.deb
mesa-amdgpu-common-dev_18.1.0-641594_i386.deb
mesa-amdgpu-omx-drivers_18.1.0-641594_amd64.deb
mesa-amdgpu-omx-drivers_18.1.0-641594_i386.deb
mesa-amdgpu-va-drivers_18.1.0-641594_amd64.deb
mesa-amdgpu-va-drivers_18.1.0-641594_i386.deb
mesa-amdgpu-vdpau-drivers_18.1.0-641594_amd64.deb
mesa-amdgpu-vdpau-drivers_18.1.0-641594_i386.deb
opencl-amdgpu-pro_18.30-641594_amd64.deb
opencl-amdgpu-pro-dev_18.30-641594_amd64.deb
opencl-amdgpu-pro-icd_18.30-641594_amd64.deb
opencl-orca-amdgpu-pro-icd_18.30-641594_amd64.deb
opencl-orca-amdgpu-pro-icd_18.30-641594_i386.deb
Packages
Release
roct-amdgpu-pro_1.0.8-641594_amd64.deb
roct-amdgpu-pro-dev_1.0.8-641594_amd64.deb
vulkan-amdgpu_18.30-641594_amd64.deb
vulkan-amdgpu_18.30-641594_i386.deb
vulkan-amdgpu-pro_18.30-641594_amd64.deb
vulkan-amdgpu-pro_18.30-641594_i386.deb
wayland-protocols-amdgpu_1.14-641594_all.deb
wsa-amdgpu_18.30-641594_amd64.deb
wsa-amdgpu_18.30-641594_i386.deb
xserver-xorg-amdgpu-video-amdgpu_18.0.99-641594_amd64.deb
xserver-xorg-amdgpu-video-amdgpu_18.0.99-641594_i386.deb
[email protected]:~/amdgpu-pro-18.30-641594$ sudo amdgpu-pro-install --compute
[sudo] password for bala:
sudo: amdgpu-pro-install: command not found
[email protected]:~/amdgpu-pro-18.30-641594$

Desconectado

#59 04-09-2018 06:00:52

bala
Usuario

Registrado: 26-07-2017
Mensajes: 110

Re: Linux tan difícil de instalar AMD GPU

https://imgur.com/a/VSuWqhl


clinfo-amdgpu-pro
opencl-amdgpu-pro-icd
amdgpu-pro-dkms
libdrm2-amdgpu-pro
libdrm-amdgpu-pro-amdgpu1

¿cómo instalar?

Ultima edición por bala (04-09-2018 06:04:21)

Desconectado

#60 04-09-2018 07:45:12

crash
Expulsado

Registrado: 25-10-2017
Mensajes: 1,049

Re: Linux tan difícil de instalar AMD GPU

estas usando una versión diferente a la que yo estaba mirando. pero dentro del script te pone lo que tienes que hacer, tan sencillo como haber hecho un amdgpu-install -h y te muestra la ayuda.
Captura%20de%20pantalla_2018-09-04_08-38-10_zpsndjqo5ke.png

sudo amdgpu-install --pro
sudo amdgpu-install --opencl=legacy

Ultima edición por crash (04-09-2018 07:56:08)

Desconectado

#61 04-09-2018 12:15:44

bala
Usuario

Registrado: 26-07-2017
Mensajes: 110

Re: Linux tan difícil de instalar AMD GPU

https://imgur.com/a/YbRy12w



[email protected]:~/amdgpu-pro-18.30-641594$ sudo amdgpu-install --opencl=legacy
sudo: amdgpu-install: command not found
[email protected]:~/amdgpu-pro-18.30-641594$ sudo amdgpu-install --pro
sudo: amdgpu-install: command not found
[email protected]:~/amdgpu-pro-18.30-641594$ sudo amdgpu-install --compute
sudo: amdgpu-install: command not found
[email protected]:~/amdgpu-pro-18.30-641594$ sudo amdgpu-install --dryrun
sudo: amdgpu-install: command not found
[email protected]:~/amdgpu-pro-18.30-641594$ sudo amdgpu-install --px
sudo: amdgpu-install: command not found
[email protected]:~/amdgpu-pro-18.30-641594$ sudo amdgpu-install --headless
sudo: amdgpu-install: command not found


[email protected]:~/amdgpu-pro-18.30-641594$ sudo amdgpu-pro-install --pro
sudo: amdgpu-pro-install: command not found
[email protected]:~/amdgpu-pro-18.30-641594$ sudo amdgpu-pro-install --opencl=legacy
sudo: amdgpu-pro-install: command not found

Ultima edición por bala (04-09-2018 12:19:27)

Desconectado

#62 04-09-2018 12:22:53

bala
Usuario

Registrado: 26-07-2017
Mensajes: 110

Re: Linux tan difícil de instalar AMD GPU

el mismo controlador 100% con éxito para instalar Ubuntu.
pero pyrit GPU nada

Desconectado

#63 04-09-2018 16:03:30

crash
Expulsado

Registrado: 25-10-2017
Mensajes: 1,049

Re: Linux tan difícil de instalar AMD GPU

acuérdate que debes de editar el script en kali, cambiando ubuntu por kali.
después hacer el proceso anterior, sino funciona eso lo puedes instalar a mano el opencl
con el comando,

sudo dpkg -i opencl-amdgpu-pro_18.30-641594_amd64.deb
opencl-amdgpu-pro-dev_18.30-641594_amd64.deb
opencl-amdgpu-pro-icd_18.30-641594_amd64.deb
libopencl1-amdgpu-pro_18.30-641594_amd64.deb
clinfo-amdgpu-pro_18.30-641594_amd64.deb

Desconectado

#64 04-09-2018 19:15:51

bala
Usuario

Registrado: 26-07-2017
Mensajes: 110

Re: Linux tan difícil de instalar AMD GPU

https://imgur.com/a/xLhvWZp



[email protected]:~/amdgpu-pro-18.30-641594$ sudo dpkg -i opencl-amdgpu-pro_18.30-641594_amd64.deb
(Reading database ... 387242 files and directories currently installed.)
Preparing to unpack opencl-amdgpu-pro_18.30-641594_amd64.deb ...
Unpacking opencl-amdgpu-pro (18.30-641594) over (18.30-641594) ...
dpkg: dependency problems prevent configuration of opencl-amdgpu-pro:
opencl-amdgpu-pro depends on amdgpu-core (= 18.30-641594); however:
  Package amdgpu-core is not installed.
opencl-amdgpu-pro depends on amdgpu-pro-core (= 18.30-641594); however:
  Package amdgpu-pro-core is not installed.
opencl-amdgpu-pro depends on amdgpu-dkms (= 18.30-641594); however:
  Package amdgpu-dkms is not installed.
opencl-amdgpu-pro depends on libdrm2-amdgpu (= 1:2.4.92-641594); however:
  Package libdrm2-amdgpu is not installed.
opencl-amdgpu-pro depends on libdrm-amdgpu-amdgpu1 (= 1:2.4.92-641594); however:
  Package libdrm-amdgpu-amdgpu1 is not installed.
opencl-amdgpu-pro depends on libdrm-amdgpu-common (= 1.0.0-641594); however:
  Package libdrm-amdgpu-common is not installed.
opencl-amdgpu-pro depends on clinfo-amdgpu-pro (= 18.30-641594); however:
  Package clinfo-amdgpu-pro is not installed.
opencl-amdgpu-pro depends on opencl-orca-amdgpu-pro-icd (= 18.30-641594); however:
  Package opencl-orca-amdgpu-pro-icd is not installed.
opencl-amdgpu-pro depends on libopencl1-amdgpu-pro (= 18.30-641594); however:
  Package libopencl1-amdgpu-pro is not installed.
opencl-amdgpu-pro depends on opencl-amdgpu-pro-icd (= 18.30-641594); however:
  Package opencl-amdgpu-pro-icd is not installed.

dpkg: error processing package opencl-amdgpu-pro (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
opencl-amdgpu-pro
[email protected]:~/amdgpu-pro-18.30-641594$

Desconectado

#65 20-09-2018 20:57:14

bala
Usuario

Registrado: 26-07-2017
Mensajes: 110

Re: Linux tan difícil de instalar AMD GPU

Hai equipo y comunidad

finalmente terminó My RX Vega 64 Pyrit list_core
Ubuntu está trabajando. amdgpu-pro-18.30-641594 controlador + AMD-APP-SDK-v3.0.130.136-GA-linux64 ..... así que estoy feliz ..
gracias por la comunidad de apoyo.
gracias especiales por Sir Crash. él ayudará mucho. graciassssssssssssssss big_smile big_smile big_smile big_smile big_smile


https://imgur.com/a/P6V4Dat

[email protected]:~$ pyrit list_cores
Pyrit 0.5.1 (C) 2008-2011 Lukas Lueg - 2015 John Mora
https://github.com/JPaulMora/Pyrit
This code is distributed under the GNU General Public License v3+

The following cores seem available...
#1:  'CPU-Core (SSE2/AES)'
#2:  'CPU-Core (SSE2/AES)'
#3:  'CPU-Core (SSE2/AES)'
#4:  'CPU-Core (SSE2/AES)'
#5:  'CPU-Core (SSE2/AES)'
#6:  'CPU-Core (SSE2/AES)'
#7:  'CPU-Core (SSE2/AES)'
#8:  'CPU-Core (SSE2/AES)'

The following OpenCL GPUs seem available...
#1:  'OpenCL-Device 'gfx900''
[email protected]:~$ pyrit benchmark
Pyrit 0.5.1 (C) 2008-2011 Lukas Lueg - 2015 John Mora
https://github.com/JPaulMora/Pyrit
This code is distributed under the GNU General Public License v3+

Running benchmark (122454.8 PMKs/s)... -

Computed 122454.79 PMKs/s total.
#1: 'CPU-Core (SSE2/AES)': 527.4 PMKs/s (RTT 2.9)
#2: 'CPU-Core (SSE2/AES)': 520.2 PMKs/s (RTT 2.9)
#3: 'CPU-Core (SSE2/AES)': 532.4 PMKs/s (RTT 3.1)
#4: 'CPU-Core (SSE2/AES)': 504.2 PMKs/s (RTT 2.8)
#5: 'CPU-Core (SSE2/AES)': 516.7 PMKs/s (RTT 2.8)
#6: 'CPU-Core (SSE2/AES)': 530.1 PMKs/s (RTT 2.9)
#7: 'CPU-Core (SSE2/AES)': 506.4 PMKs/s (RTT 3.1)
#8: 'CPU-Core (SSE2/AES)': 538.8 PMKs/s (RTT 2.9)
OpenCL:
#1: 'OpenCL-Device 'gfx900'': 135905.7 PMKs/s (RTT 1.3)
[email protected]:~$

Ultima edición por bala (21-09-2018 04:32:05)

Desconectado

#66 21-09-2018 12:10:13

kcdtv
Administrator

Registrado: 14-11-2014
Mensajes: 5,255

Re: Linux tan difícil de instalar AMD GPU

¡Enhorabuena!

gracias especiales por Sir Crash. él ayudará mucho. graciassssssssssssssss big_smile big_smile big_smile big_smile big_smile

Se merece una medalla porque no fue nada fácil... ¡Vaya hilo! big_smile

Desconectado

#67 21-09-2018 19:44:52

bala
Usuario

Registrado: 26-07-2017
Mensajes: 110

Re: Linux tan difícil de instalar AMD GPU

yaaaa big_smile big_smile big_smile

Desconectado

#68 22-09-2018 18:17:09

crash
Expulsado

Registrado: 25-10-2017
Mensajes: 1,049

Re: Linux tan difícil de instalar AMD GPU

me alegro por ti bala, que al final lo hayas conseguido.  plus_un  biere

Desconectado

#69 14-04-2020 20:08:23

JPJ
Usuario

Registrado: 01-01-2019
Mensajes: 17

Re: Linux tan difícil de instalar AMD GPU

Buenas tardes compadres.

Tengo problemas similares a @bala para instalar drivers AMD.
Dispongo de 2 gráficas, una incorporada en el procesador, y otra dedicada:

lspci -nnk | grep -i -EA3 "3d|display|vga"
00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Sumo [Radeon HD 6520G] [1002:9647]
        Subsystem: Acer Incorporated [ALI] Sumo [Radeon HD 6520G] [1025:059e]
        Kernel driver in use: radeon
        Kernel modules: radeon
--
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Thames [Radeon HD 7500M/7600M Series] [1002:6840] (rev ff)
        Kernel driver in use: radeon
        Kernel modules: radeon

Por lo que veo, ambos drivers están instalados (Kernel driver in use: radeon), cosa que he descubierto después de varias horas...en fin... hmm

Pero ya que estoy con esto, me gustaría resolver alguna duda.

Por lo que he estado leyendo, existen 3 tipos de drivers ATI/AMD:
  - Privativos / Del fabricante (fglrx).
  - Open Source (AMDGPU y AMDGPU-Pro)
  - Radeon (esto no me queda muy claro).

Tengo el sistema y kernel actualizados y he instalado/actualizado las dependencias que según he leído, son necesarias:

sudo apt install xorg
sudo apt install xserver-xorg-core
sudo apt install xserver-xorg-video-amdgpu
sudo apt install git python2.7-dev mesa-utils libssl-dev zlib1g-dev libpcap-dev
sudo apt install ocl-icd-opencl-dev
sudo apt install python-dev
sudo apt install openssl

He tratado de instalar los drivers de la Radeon HD 6520G de varias maneras:

1) Desde la web oficial de AMD: https://www.amd.com/en/support/apu/amd- … n-hd-6520g

He descargado el de "Linux x86_64" pero tras descomprimir e intentar instalar, obtengo la siguiente salida:

sudo sh ./AMD-Catalyst-15.9-Linux-installer-15.201.1151-x86.x86_64.run
Created directory fglrx-install.Kp2QyS
Verifying archive integrity... All good.
Uncompressing AMD Catalyst(TM) Proprietary Driver-15.201.1151................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
=====================================================================
 AMD Catalyst(TM) Proprietary Driver Installer/Packager 
=====================================================================

error: Detected X Server version 'XServer 1.20.8_64a' is not supported. Supported versions are X.Org 6.9 or later, up to XServer 1.10 (default:v2:x86_64:lib32:XServer 1.20.8_64a:none:5.4.0-kali4-amd64:)
Installation will not proceed.

2) AMDGPU-Pro de la Web oficial de AMD: https://www.amd.com/en/support/kb/faq/gpu-635 (AMDGPU-PRO Driver Version 17.40 for Ubuntu 16.04.3)

Pero cuando intento instalar, aparece el error de SO soportado: (claro, es para Ubuntu)

./amdgpu-pro-install –y
Unsupported OS

Tengo 2 tarjetas gráficas y digamos que quiero instalar los drivers oficiales de AMD, o los AMDGPU-Pro en mi Kali de 64 bits, para ambas tarjetas.

grep VERSION /etc/os-release
VERSION="2020.2"
VERSION_ID="2020.2"
VERSION_CODENAME="kali-rolling"

He visto por ahí varias formas de hacerlo, pero toquetean mucho los repos y no me fio, la verdad...

Gracias de antemano compañ[email protected]


Saludos!

Ultima edición por JPJ (14-04-2020 20:09:56)

Desconectado

#70 15-04-2020 13:40:31

kcdtv
Administrator

Registrado: 14-11-2014
Mensajes: 5,255

Re: Linux tan difícil de instalar AMD GPU

Tengo problemas similares a @bala

WoW. Significa que entiendes algo en este tema infumable. Un aplauso big_smile
Sobre tu problema no sabría que decirte... No tengo tarjeta ATI para trastear de mi lado y desconozco este material. 
La documentación oficial y los drivers catalyst linux son del 2015... No se lo curan mucho.
No han hecho su código correctamente ya que para ellos una versión 1.XX.X es inferior a una 6.X
El problema es que no es código libre y no puedes arreglar esta tontería... No sé amigo... Si veo algo relevante te lo seañalaré de momento no se me ocurre nada  para darle la vuelta a esta situación

Desconectado

#71 15-04-2020 20:59:04

JPJ
Usuario

Registrado: 01-01-2019
Mensajes: 17

Re: Linux tan difícil de instalar AMD GPU

Gracias x la info kc,
seguiré investigando.
Cuando sepa algo y pruebe, os lo hago saber.

cool

Desconectado

Anuncio

Wifi-libre.com: El libre pensamiento para un internet libre / Regístrese ahora

Temas similares

Tema Respuestas Vistas Ultimo mensaje
Pegado:
483 244718 Ayer 16:28:25 por kcdtv
3 178 Ayer 16:21:19 por kcdtv
Hola a todos por karp1n
1 75 30-11-2020 02:09:43 por kcdtv
3 177 30-11-2020 02:06:01 por kcdtv
Antivirus para android por cigarrero
1 57 28-11-2020 16:32:17 por kcdtv

Pie de página

Información del usuario

Ultimo usuario registrado: RomuKiro
Usuarios registrados conectados: 0
Invitados conectados: 6

Estadisticas de los foros

Número total de usuarios registrados: 2,044
Número total de temas: 1,474
Número total de mensajes: 14,434

Máx. usuarios conectados: 373 el 30-09-2019 15:04:36