El libre pensamiento para un internet libre

No estas registrado.  

Anuncio

Wifi-libre.com: El libre pensamiento para un internet libre / Regístrese ahora

#1 16-01-2019 00:05:59

Wey
Usuario

Registrado: 17-12-2018
Mensajes: 7

Kali Linux no detecta la Awus1900 después de la instalación

Hola,

Estoy intentando instalar la Awus1900 en Kali Linux.
He hecho una partición de 20 gb en mi portátil que tiene Windows 10 y con Virtual Box ahí he istalado Kali Linux.
He configurado la red para la máquina virtual, seleccionando Conectado a: Adaptador Puente  Nombre: Inter(R) Dual Band Wireless-AC 3165
Después he editado el archivo sources.list para el tema de actualizaciones y he creado una cuenta de usuario.
Desde la cuenta de usuario, en la terminal he escrito:

sudo apt update

Y cuando ha terminado he puesto:

sudo apt install realtek-rt188xau-dkms

Cuando ha terminado he reiniciado el ordenador y he echufado la awus1900 al usb de mi portátil.
Si clico en la parte derecha superior no aparece un apartado que se llame Inalámbrica, con lo que entiendo Kali Linux no se está comunicando con la Awus 1900. He mirado el kernel con uname -r y me sale 4.18. Lo digo porque sudo apt install realtek-rt188xau-dkms terminó mencioando algo del kernel, pero no puso al final algo en plan "HECHO", apareció [email protected], pero no tengo claro si se completó el proceso anterior.

Perdón si pregunto una tontería, pero soy muy noob, me ha costado bastante llegar hasta este paso. Por eso os agradecería que si me aclaráis algo que me lo expliquéis para dummies, porque me atasco constantemente con cualquier chorrada.

Muchas gracias y un saludo!

Ultima edición por Wey (16-01-2019 22:43:30)

Desconectado

Anuncio

Wifi-libre.com: El libre pensamiento para un internet libre / Regístrese ahora

#2 16-01-2019 03:35:02

javierbu
Usuario

Registrado: 09-08-2018
Mensajes: 87

Re: Kali Linux no detecta la Awus1900 después de la instalación

Hola.

No dispongo de ese dispositivo, pero te puedo comentar un par de cosas que quiza te ayuden un poco.

Cuando instalas kali, o cualquier otro OS en una maquina virtual, no es necesario hacer una particion en el disco para ello.

Como no lo comentas, no podemos estar seguros de que virtualbox haya tomado el control del dispositivo usb y lo haya conectado a tu kali virtual. No estoy muy seguro, ya que no uso virtualbox, pero creo que debes instalar  guest additions para que tu  maquina anfitriona (tu portatil) comparta los usb con tu maquina virtual (kali)

Para ver si el dispositivo realmente se ha conectado a kali, podemos verlo si nos muestras la salida de los siguientes comandos:

Este primer comando debas hacerlo inmediatamente despues de desconectar y volver a conectar el dispositivo al puerto usb:

sudo dmesg | tail -30

Una vez conectado el dispositivo al usb, los siguientes comandos:

sudo airmon-ng
lsusb

Con la salida de esos comandos ya podemos ver si tu kali-linux reconoce al menos el puerto usb, aunque no reconozca aun el dispositivo como lo que es todavia.

No hay problema en que vuelvas a instalar el driver dkms (sudo apt install realtek-rt188xau-dkms). Si ya esta instalado, apt te dira que ya esta en su version mas reciente, y si te da algun tipo de error, seria necesario que lo mostraras aqui.

Desconectado

#3 16-01-2019 10:16:34

kcdtv
Administrator

Registrado: 14-11-2014
Mensajes: 4,721

Re: Kali Linux no detecta la Awus1900 después de la instalación

Procura usar la opción texto formateado para poner las lineas de ordenes.

insertarcodigo.jpg

Hubieras tenido que enseñarnos la salida de consola después ejecutar las ordenes. Las ordenes solas no sirven de nada: ¿Cómo quieres que veamos el error?
Muevo tu tema en el foro Kali Linux.
Por favor, edita el titulo para hacer un descriptivo: Prohibida la palabra "problema" que no dice absolutamente nada.  big_smile

Desconectado

#4 16-01-2019 23:39:57

Wey
Usuario

Registrado: 17-12-2018
Mensajes: 7

Re: Kali Linux no detecta la Awus1900 después de la instalación

Hola, gracias por vuestras respuestas. He editado el título, espero que ahora sea más fácil localizar este hilo para quienes tengan el mismo problema que yo en el futuro.

Pongo a continuación lo que devuelve el terminal cuando introduzco los comandos que me comentas para ver si Kali se comunica con el puerto usb:

[email protected]:~$ sudo dmesg | tail -30
[sudo] password for usuario: 
[    2.595463] vbg_heartbeat_init: Setting up heartbeat to trigger every 2000 milliseconds
[    2.595540] input: VirtualBox mouse integration as /devices/pci0000:00/0000:00:04.0/input/input6
[    2.612001] input: PC Speaker as /devices/platform/pcspkr/input/input7
[    2.624213] vboxguest: misc device minor 58, IRQ 11, I/O port d040, MMIO at 0x00000000f0400000 (size 0x0000000000400000)
[    2.725559] RAPL PMU: API unit is 2^-32 Joules, 5 fixed counters, 10737418240 ms ovfl timer
[    2.725560] RAPL PMU: hw unit of domain pp0-core 2^-0 Joules
[    2.725561] RAPL PMU: hw unit of domain package 2^-0 Joules
[    2.725561] RAPL PMU: hw unit of domain dram 2^-0 Joules
[    2.725562] RAPL PMU: hw unit of domain pp1-gpu 2^-0 Joules
[    2.725562] RAPL PMU: hw unit of domain psys 2^-0 Joules
[    2.773394] vboxvideo: module is from the staging directory, the quality is unknown, you have been warned.
[    2.805419] PCI Interrupt Link [LNKA] enabled at IRQ 11
[    2.808668] [drm] VRAM 00600000
[    2.812536] [TTM] Zone  kernel: Available graphics memory: 1022550 kiB
[    2.812537] [TTM] Initializing pool allocator
[    2.812540] [TTM] Initializing DMA pool allocator
[    2.814070] fbcon: vboxdrmfb (fb0) is primary device
[    2.845666] Console: switching to colour frame buffer device 100x37
[    2.849862] vboxvideo 0000:00:02.0: fb0: vboxdrmfb frame buffer device
[    2.849880] [drm] Initialized vboxvideo 1.0.0 20130823 for 0000:00:02.0 on minor 0
[    3.129350] Adding 2095100k swap on /dev/sda5.  Priority:-2 extents:1 across:2095100k FS
[    3.660426] snd_intel8x0 0000:00:05.0: intel8x0_measure_ac97_clock: measured 57062 usecs (2400 samples)
[    3.660428] snd_intel8x0 0000:00:05.0: clocking to 54780
[    3.824919] random: crng init done
[    3.824921] random: 7 urandom warning(s) missed due to ratelimiting
[    4.262394] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[    4.262613] pcnet32 0000:00:03.0 eth0: link up, 100Mbps, full-duplex
[    6.032686] fuse init (API version 7.27)
[   51.733928] ISO 9660 Extensions: Microsoft Joliet Level 3
[   51.749144] ISO 9660 Extensions: RRIP_1991A
[email protected]:~$ sudo airmon-ng

PHY	Interface	Driver		Chipset


[email protected]:~$ lsusb
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
[email protected]:~$ 

Después volví a instalar el driver y me salía lo siguiente:

[email protected]:~$ sudo apt install realtek-rt188xxau-dkms
[sudo] password for usuario: 
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
E: No se ha podido localizar el paquete realtek-rt188xxau-dkms

(Cuando lo hice por primera vez sí que localizaba el paquete y estaba un buen rato instalándolo)

Muchísimas gracias y un saludo

Desconectado

#5 17-01-2019 02:18:32

kcdtv
Administrator

Registrado: 14-11-2014
Mensajes: 4,721

Re: Kali Linux no detecta la Awus1900 después de la instalación

Se agradece tu esfuerzo biere y has perfectamente entendido el porqué wink  (Lo que te pasa puede pasar a otro)
En tu caso el síntoma es muy claro: No te detecta el chisme USB.

[email protected]:~$ lsusb
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Aunque no tengas los drivers instalados se tendría que detectar el dispositivo "físicamente".
  * Deberías obtener en consola:

lsusb
[blablablabla]  Realtek Semiconductor Corp. 

  - Dices estar en un maquina virtual: Repasa cuidadosamente la configuración de los USB. Necesitas subir a por lo menos USB 2.0, con USB 1.0 no aguanta (si enciende) 
  - Luego dices haber editado la lista de repositorios: Pero si instalaste Kali 2018.4 ya no hace falta editar nada. Asegúrate de tener tu lista como debido (el "unable to locate packet " da a pensar que a"algo" no va bien)
   - Después una instalación lo normal es hacer una actualización, Antes de instalar el driver.

sudo apt update
sudo apt full-upgrade

 
  Y para que sea bien limpio un pequeño reboot.

sudo systemctl reboot

  Si no haces así puedes quedarte con las cabeceras del kernel anterior y puede ser que tu instalación no sirve de nada al próximo reinicio ( se sube de kernel y tu instalación no cuadra más) .
  Lo primero es lo primero y es hacer que te detecte "físicamente" el dispositivo. Algo no está bien con tu maquina virtual.

Desconectado

#6 17-01-2019 02:59:22

javierbu
Usuario

Registrado: 09-08-2018
Mensajes: 87

Re: Kali Linux no detecta la Awus1900 después de la instalación

Como te dice kcdtv, tu maquina virtual no detecta el usb de tu maquina anfitriona.

Primero instala guest additions de virtualbox para que puedas usar los usb de tu maquina anfitriona en tu maquina virtual.

https://docs.oracle.com/cd/E36500_01/E3 … tions.html <-- aqui te dice como hacerlo

Ese es el primer paso que debes seguir y creo que con eso bastara para que tu maquina virtual reconozca los usb.

Apt no encuentra el paquete a instalar quiza porque lo has escrito mal. Quiza hiciste un copy/paste de lo que yo escribi, y yo hice lo mismo de lo que tu escribiste, y lo escribiste mal en tu primer post. No es realtek-rt188xxau-dkms, es realtek-rtl88xxau-dkms. Hay un 1 donde deberia haber una l.

Asi que vuelve a intentarlo, pero esta vez bien escrito a ver que pasa.

Una vez  hayas instalado guest additions, y el paquete realtek-rtl88xxau-dkms, vuelve a probar y si sigue sin aparecer tu dispositivo, vuelve a hacer los comandos que te dije y nos los muestras.

Tampoco esta de mas que nos ense;es los repositorios que tienes. Es muy tipico al ser novato seguir tutoriales que desinforman y no hacen bien las cosas y puedes llegar a estropear el sistema. Tal y como te han comentado, no deberias haber cambiado los repositorios que vienen en kali-linux. Esto es algo peligroso para el sistema y no se debe hacer a la ligera. El paquete que quieres instalar lo encuentras en los repositorios oficiales que vienen de serie en kali-linux.

Para mostrarnos los repositorios, haz:

cat /etc/apt/sources.list

Desconectado

#7 18-01-2019 22:43:10

Wey
Usuario

Registrado: 17-12-2018
Mensajes: 7

Re: Kali Linux no detecta la Awus1900 después de la instalación

Hola, gracias por las respuestas! Respondo por partes:

kcdtv escribió:

Necesitas subir a por lo menos USB 2.0, con USB 1.0 no aguanta (si enciende)

Mi ordenador tiene puertos usb 3.0, ¿lo de 1.0 lo ves en el código que pegué o por qué me lo comentas?

kcdtv escribió:

Luego dices haber editado la lista de repositorios: Pero si instalaste Kali 2018.4 ya no hace falta editar nada. Asegúrate de tener tu lista como debido (el "unable to locate packet " da a pensar que a"algo" no va bien)

Acabo de comprobar que instalé Kali 2018.4. La lista de repositorios inicialmente la tenía así:

343kpao.jpg

Y después, según vi en esta dirección https://docs.kali.org/general-use/kali- … positories, la edité para dejarla así:

35j9r3t.jpg


kcdtv escribió:

Después una instalación lo normal es hacer una actualización, Antes de instalar el driver.

sudo apt update
sudo apt full-upgrade

 
  Y para que sea bien limpio un pequeño reboot.

sudo systemctl reboot

Yo lo que hice fue:

sudo apt update

Y reinicié manualmente el ordenador, no con comandos. Creo que intenté instalar el driver antes de reiniciar, pero no lo recuerdo bien.

jabierbu escribió:

Primero instala guest additions de virtualbox

Lo he intentado pero no me funciona, en Dispositivos, en vez de "Instalar Guest Additions" me aparece "Instalar imagen de CD de Guest Additions", y al clicar ahí me sale este error:

30v0sw8.jpg

En la configuración de la máquina virtual, en Almacenamiento me aparece lo siguiente:

He leído que añadiendo otra unidad de cd hay gente a la que se le soluciona, pero no sé qué iso seleccionar, y si la dejo vacía, pues no aparece nada nuevo.
af91fp.jpg

jabierbu escribió:

Apt no encuentra el paquete a instalar quiza porque lo has escrito mal. Quiza hiciste un copy/paste de lo que yo escribi, y yo hice lo mismo de lo que tu escribiste, y lo escribiste mal en tu primer post. No es realtek-rt188xxau-dkms, es realtek-rtl88xxau-dkms. Hay un 1 donde deberia haber una l.
Asi que vuelve a intentarlo, pero esta vez bien escrito a ver que pasa

En su momento me di cuenta de lo que comentas y lo escribí bien (si te fijas en el código que pegué en mi respuesta a vuestras indicaciones, se ve que lo escribí con dos x y el 1, y lo probé varias veces y siempre me daba ese resultado.


jabierbu escribió:

Tampoco esta de mas que nos ense;es los repositorios que tienes. Es muy tipico al ser novato seguir tutoriales que desinforman y no hacen bien las cosas y puedes llegar a estropear el sistema. Tal y como te han comentado, no deberias haber cambiado los repositorios que vienen en kali-linux. Esto es algo peligroso para el sistema y no se debe hacer a la ligera. El paquete que quieres instalar lo encuentras en los repositorios oficiales que vienen de serie en kali-linux.

En la imagen que puse arriba donde muestro los repositorios que tengo, aparece un comentario diciendo que instalé Kali desde un pequeño usb.
La verdad es que yo pensaba que no jaja. Quiero decir que la instalación de Kali fue a base de varios intentos, porque cuando llegaba a la parte de "Particionado del Disco", no entendía muy bien qué implicaciones tenía las opciones que escogía la gente en los videotutoriales que vi, así que cancelé la instalación varias veces, porque me daba miedo cargarme la instalación de Windows. Después vi un tutorial que lo hacía desde un usb, haciendo una partición de 20 gb, y pensé que así sería imposible cargarme nada de Windows y lo intenté por ahí, pero no me funcionaba el ratón, así que tuve que apagar el ordenador dándole al botón, porque al principio iba solucionando la instalación usando la tecla Tab y Enter del teclado, pero llegué a una pantalla en que Tab no resaltaba la opción que yo necesitaba, por lo que hice eso de apagar con el botón.
Y después pues instalé sin el método usb, pero seguí con la opción de la partición de 20 gb, que fue cuando ya lo conseguí.

Igual con esto que os explico ya entendéis por que no me funciona nada...ih, pero bueno, comentadme como lo veis.

Gracias!!

Ultima edición por Wey (18-01-2019 22:45:20)

Desconectado

#8 18-01-2019 23:21:30

javierbu
Usuario

Registrado: 09-08-2018
Mensajes: 87

Re: Kali Linux no detecta la Awus1900 después de la instalación

Lo primero que debes hacer es instalar si o si guest additions para que te reconozca los usb. Ha de haber miles de tutoriales en internet para ello. Imagino que solo debes habilitar la unidad optica de dvd/cd y automaticamente el iso de guest addditions te aparecera en ella al intentar instalarlos. No te puedo ayudar mas de ahi porque como ya te dije no uso virtualbox. Me gusta bastante mas vmware.

Respecto al paquete en cuestion del driver de tu dispositivo, sí esta en esos repositorios que tienes. Si trataste de instalarlo despues de hacer el apt update, no entiendo como no lo encuentra. De todos modos antes debes solucionar que virtualbox reconozca los usb de tu portatil con guest additions.

Suerte y no te desesperes. Asi se aprende.

Desconectado

#9 19-01-2019 01:38:09

kcdtv
Administrator

Registrado: 14-11-2014
Mensajes: 4,721

Re: Kali Linux no detecta la Awus1900 después de la instalación

Unas precisiones

Mi ordenador tiene puertos usb 3.0, ¿lo de 1.0 lo ves en el código que pegué o por qué me lo comentas?

Lo imagino, por lo menos lo espero para tí. big_smile Lo digo efectivamente por la salida de lsusb. Tu maquina virtual no detecta ningún puerto USB 2,0 o 3.0.   

Yo lo que hice fue:

sudo apt update

Y reinicié manualmente el ordenador, no con comandos. Creo que intenté instalar el driver antes de reiniciar, pero no lo recuerdo bien.

Así no has actualizado nada. El comando update es para actualizar tus repositorios. Pero sespués esto debes ejecutar

sudo apt full-upgrade

para instalar las actualizaciones disponibles.
Otra precisión:
Lo que has hecho cuando has editado tu lista es añadir el acceso a las "fuentes" de los paquetes *.deb. Es más bien para desarrolladores que quieren trabajar con las fuentes pero no es un problema. Tu lista está OK. wink
  Esto dicho no es el problema por ahora... Chapter 4. Guest Additions
Tampoco te puedo ayudar: No tengo una PC potente y no suelo usar maquinas virtuales. Las pocas veces que lo he hecho era desde Ubuntu y no he tenido problemas ya que la "guest addition y otras cosas" se instalan solitas desde los repositorios Ubuntu si instalas los "extras". 
  Personalmente creo que es un poco error empezar con Kali Linux si te estás familiarizando con el universo GNU-Linux.
Pasaría de distribución "para hacking" y me instalaría una distribución para "todo tipo de publico": Debian, Ubuntu, Linux Mint...
Debian es quizá un poquito menos amigable que Ubuntu o Linux Mint pero si controlas debian te será aún más fácil moverte en Kali.
Luego, para empezar tu viaje en el mundo del wifi, no necesitas muchas cosas: Aircrack-ng, reaver y poco más.
Instalar aircrack-ng y reaver es pan comido, aircrack-ng propone incluso (no hace mucho) paquetes hechos para todos estos sistemas.

Desconectado

#10 20-01-2019 00:45:20

Wey
Usuario

Registrado: 17-12-2018
Mensajes: 7

Re: Kali Linux no detecta la Awus1900 después de la instalación

Hola,

Gracias por las respuestas. Contando que parecía que la máquina no estaba muy bien y contando que no me iba a servir, me puse a probar cosas sin mucho reparo de si era el orden correcto o algo redundante, según iba viendo videotutoriales. Hice

Instalé el Extension Pack de Virtual Box que me permitió configurar el usb en 3.0 y le puse un filtro.
En la terminal hice:

apt full-upgrade
apt-get install virtualbox-guest-x11
apt-get dist-upgrade
apt install dkms && apt-get install bc && apt-get install build-essential && apt-get install linux-headers-$(uname -r)
apt-cache search linux headers
apt-get install linux-headers-4.19.0-kali1-all-amd64
apt-cache search linux-image
apt-get install linux-image-4.19.0-kali1-amd64

Al enchufar la Awus1900 en uno de los 2 usb (imagino que es el 3.0), parece que lo reconoce (aparece un apartado Inalámbrica y se detectan redes wifi)

Los comandos que me había indicado Javierbu, arrojan estos resultados:

[email protected]:~# dmesg | tail -30
[    3.506615] snd_intel8x0 0000:00:05.0: intel8x0_measure_ac97_clock: measured 57565 usecs (2640 samples)
[    3.506617] snd_intel8x0 0000:00:05.0: clocking to 50238
[    4.195154] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[    4.195357] pcnet32 0000:00:03.0 eth0: link up, 100Mbps, full-duplex
[    5.448264] fuse init (API version 7.27)
[   32.356762] ISO 9660 Extensions: Microsoft Joliet Level 3
[   32.366025] ISO 9660 Extensions: RRIP_1991A
[  128.859016] usb 1-1: new high-speed USB device number 2 using xhci_hcd
[  129.204886] usb 1-1: New USB device found, idVendor=0bda, idProduct=8813, bcdDevice= 0.00
[  129.204888] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  129.204890] usb 1-1: Product: 802.11ac NIC
[  129.204891] usb 1-1: Manufacturer: Realtek
[  129.204892] usb 1-1: SerialNumber: 123456
[  130.123542] usb 1-1: reset high-speed USB device number 2 using xhci_hcd
[  130.250696] usb 1-1: device descriptor read/64, error -32
[  130.486678] usb 1-1: device descriptor read/64, error -32
[  131.579454] usbcore: registered new interface driver rtl88xxau
[  131.583715] usb 1-1: USB disconnect, device number 2
[  131.734719] usb 2-1: new SuperSpeed Gen 1 USB device number 2 using xhci_hcd
[  131.756524] usb 2-1: Int endpoint with wBytesPerInterval of 512 in config 1 interface 0 altsetting 0 ep 133: setting to 64
[  131.757416] usb 2-1: New USB device found, idVendor=0bda, idProduct=8813, bcdDevice= 0.00
[  131.757417] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  131.757419] usb 2-1: Product: 802.11ac NIC
[  131.757420] usb 2-1: Manufacturer: Realtek
[  131.757421] usb 2-1: SerialNumber: 123456
[  132.542749] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[  133.630673] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[  133.632664] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[  133.633556] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[  133.693058] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[email protected]:~# airmon-ng

PHY	Interface	Driver		Chipset

phy0	wlan0		88XXau		Realtek Semiconductor Corp. 

[email protected]:~# lsusb
Bus 002 Device 002: ID 0bda:8813 Realtek Semiconductor Corp. 
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
[email protected]:~# 

Significa que está ok?

Saludos!

Desconectado

#11 20-01-2019 00:55:39

javierbu
Usuario

Registrado: 09-08-2018
Mensajes: 87

Re: Kali Linux no detecta la Awus1900 después de la instalación

Felicidades. Ya lo tienes funcionando.

Al final guest additions lo tenias en los repositorios y no habia que complicarse la vida.

No se si es norma o cada cual lo hace como le da la gana, pero los puertos usb 3,0 suelen venir de color azul en su interior.

Un peque;o apunte:

Para familiarizarte con linux, ya seria bueno que entendieras que he cada comando. En la serie de comandos que dices que hiciste, hay varias repeticiones que realmente sobran.

Desconectado

#12 20-01-2019 14:17:57

kcdtv
Administrator

Registrado: 14-11-2014
Mensajes: 4,721

Re: Kali Linux no detecta la Awus1900 después de la instalación

¡Bien hecho! biere
Ves que ahora el resultado de lsusb es completamente diferente: Se detecta la Alfa (chip wifi Realtek) y tienes a tus puertos USB 2.0 y 3.0

javierbu escribió:

No se si es norma o cada cual lo hace como le da la gana, pero los puertos usb 3,0 suelen venir de color azul en su interior

Según leo en Tom's Hardware la "moda" viene de la "USB-IF's" que es para el USB algo comparable a lo que es la WiFi-alliance para el WiFi. El color azúl para USB 3.0 no es una norma: Más bien una recomendación que forma parte del plan marketing de la USB-IF's para promocionar el USB 3.0. O sea: No es obligatorio.   

javierbu escribió:

En la serie de comandos que dices que hiciste, hay varias repeticiones que realmente sobran.

Más de la mitad de las ordenes sobran. big_smile
@ Wey no te tiro la piedra ni mucho menos: Tienes un dispositivo y quieres hacerlo funcionar. Todos hemos copìado y pegado ordenes sin saber muy bien que hacían por qué estábamos en apuros big_smile
Pero ten en cuenta lo que te dice javierbu... Porque tarde o temprano vas a tener que entender lo que haces. Y esto pasa por familiarizarse con la consola linux que es la herramienta de base para usar tu Sistema Operativo.
Todos los comandos que usaste son comandos apt. Deberías aprovechar la oportunidad para documentarte sobre esta potente herramienta que es absolutamente fundamental si usas un sistema basado en debian: Aptitude (apt): Lo que uno debe saber para disfrutar de su Kali Linux  aptitude

Desconectado

#13 20-01-2019 21:30:15

Wey
Usuario

Registrado: 17-12-2018
Mensajes: 7

Re: Kali Linux no detecta la Awus1900 después de la instalación

Hola! Muchas gracias por vuestra ayuda!

javierbu escribió:

No se si es norma o cada cual lo hace como le da la gana, pero los puertos usb 3,0 suelen venir de color azul en su interior.

Un peque;o apunte:

Para familiarizarte con linux, ya seria bueno que entendieras que he cada comando. En la serie de comandos que dices que hiciste, hay varias repeticiones que realmente sobran.

En mi caso, el 3.0 no tiene color azul en su interior. Y sí, tengo que ponerme las pilas con esto!

kcdtv escribió:

Todos los comandos que usaste son comandos apt. Deberías aprovechar la oportunidad para documentarte sobre esta potente herramienta que es absolutamente fundamental si usas un sistema basado en debian: Aptitude (apt): Lo que uno debe saber para disfrutar de su Kali Linux  aptitude

Gracias por el enlace! Me queda mucho camino! Se puede cerrar el hilo.

Saludos y gracias!

Desconectado

#14 21-01-2019 15:50:07

kcdtv
Administrator

Registrado: 14-11-2014
Mensajes: 4,721

Re: Kali Linux no detecta la Awus1900 después de la instalación

No cerramos los hilos al no ser que sean "problemáticos".

Me queda mucho camino!

Esto vale para [email protected] smile Tampoco cuesta mucho manejar apt y es muy practico, te hace ahorrar muchísimo tiempo.

Desconectado

Anuncio

Wifi-highpower.es es distribuidor oficial de Alfa Network

Temas similares

Tema Respuestas Vistas Ultimo mensaje
Escaneo de Redes Wifi por Hunter310#
3 94 Hoy 15:51:45 por kcdtv
1 87 Hoy 14:51:28 por kcdtv
8 2430 Hoy 14:28:15 por kcdtv
Pegado:
Pegado:: Script multiuso wifi para Kali y otras distros por v1s1t0r  [ 1 2 3 13 ]
322 20735 Hoy 13:02:07 por v1s1t0r
89 43619 Ayer 19:59:00 por kcdtv

Pie de página

Información del usuario

Ultimo usuario registrado: nick19622
Usuarios registrados conectados: 0
Invitados conectados: 15

Estadisticas de los foros

Número total de usuarios registrados: 1,391
Número total de temas: 1,268
Número total de mensajes: 13,032

Máx. usuarios conectados: 74 el 13-11-2018 18:47:20