El libre pensamiento para un internet libre

No estas registrado.  

Anuncio

Wifi-libre.com: El libre pensamiento para un internet libre / Regístrese ahora

#1 04-10-2018 01:08:25

ahinoa789
Usuario

Registrado: 04-10-2018
Mensajes: 5

kali detecta el adaptador pero no ve las redes

Hola a todos,

Instale el kail en virtualbox y detecta perfectamente el adaptador wifi pero no ve ninguna de las redes que llegan y que el mismo adaptador recibe en el sistema anfitrión.

Tampoco puedo culpar al adaptador ya que fuera del kali funciona bien. Incluso también otro Windows que tengo en otra maq virtual me permite acceder a internet, asique no se que puedo hacer.

Quedo a la espera de que me puedan dar alguna idea. Muchas gracias!!

Ahinoa

Desconectado

Anuncio

Wifi-libre.com: El libre pensamiento para un internet libre / Regístrese ahora

#2 04-10-2018 12:49:28

kcdtv
Administrator

Registrado: 14-11-2014
Mensajes: 5,597

Re: kali detecta el adaptador pero no ve las redes

[email protected] a wifi-libre. smile
No se te puede decir nada a falta de tener información concreta.
¿De qué tarjeta se trata? ¿Qué chipset lleva? Cuando dices que "está detectada perfectamente": ¿Te refieres a network manager? ¿Has probado escanear con iw?

Desconectado

#3 04-10-2018 21:07:38

ahinoa789
Usuario

Registrado: 04-10-2018
Mensajes: 5

Re: kali detecta el adaptador pero no ve las redes

Hola kcdtv.
Adjunto capturas de pantalla de ifconfig, airmon que pone la tarjeta en modo monitor y airodump que no muestra ninguna red.
Digo que detecta la tarjeta porque la pone en modo monitor.
Esto igual lo he hecho anteriormente en BackTrack y WifiSlax (no ahora) y ha funcionado bien
No se visualizan las imágenes que subí. No se si así debe ser o tengo que hacer algo. Avisame. Un saludo

Desconectado

#4 05-10-2018 07:29:24

Patcher
waircut

Registrado: 14-01-2016
Mensajes: 652

Re: kali detecta el adaptador pero no ve las redes

Hola, no hagas repost en su lugar edita el mensaje anterior.

Las imágenes no se ven. ¿Por que no empiezas por responder a las preguntas que te ha hecho kdctv y vemos si así avanzamos algo?.

Desconectado

#5 05-10-2018 11:33:41

kcdtv
Administrator

Registrado: 14-11-2014
Mensajes: 5,597

Re: kali detecta el adaptador pero no ve las redes

Al final es mejor si no has conseguido insertar las imágenes: Es mil veces preferible tener un copiado-pegado de las salidas de consola. No se hace debugging con imágenes: Se hace copiando y pegando las salidas de consola. Empleando la opción "texto formateado"

Adjunto capturas de pantalla de ifconfig, airmon que pone la tarjeta en modo monitor y airodump que no muestra ninguna red.

Entonces el problema es en modo monitor y es con airodump-ng... Por lo menos he aprendido algo con tu mensaje porque hasta ahora yo pensaba que hablabas de Network Manager en modo managed. big_smile
-  No dices si funciona con Network Manager o si puedes escanear con iw o wpa_cli. No estaría de más saberlo... tongue
  - Deduzco que tu adaptador wifi es viejo visto que lo usaste con "backtrack"; pero aún ni has dicho cual es...
En espera de estas salidas de consola (copiadas y pegadas)

Desconectado

#6 05-10-2018 12:41:06

crash
Expulsado

Registrado: 25-10-2017
Mensajes: 1,049

Re: kali detecta el adaptador pero no ve las redes

si estas en virtualbox, y estas usando la conexión en ambos sistemas, anfitrión y virtual, este te la creara como conexión eth0, supongo que la tendrás en nat. y que estas usando virtualbox como administrador.

Desconectado

#7 05-10-2018 12:52:36

Patcher
waircut

Registrado: 14-01-2016
Mensajes: 652

Re: kali detecta el adaptador pero no ve las redes

Eso que comentas Crash, yo ya lo habia pensado tambien, pero sólo aplicaría si se tratase de una tarjeta interna por que si se trata de una tarjeta USB, lo normal es que capture el dipositivo USB desde la máquina virtual porlo que dejaría de estar disponible en el host. Por eso digo que antes de nada es necesario que responda a las preguntas que se le han hecho.

Desconectado

#8 05-10-2018 12:56:43

crash
Expulsado

Registrado: 25-10-2017
Mensajes: 1,049

Re: kali detecta el adaptador pero no ve las redes

no, se aplica a una tarjeta interna. con un usb tambien pasa segun cómo esté configurada, si está en nat la usa como dispositivo interno, teniendo en ambos conexion de red. y mostrándonos la interfaz en el sistema virtual como eth0.

puedes probarlo si  tienes virtualbox y ponerlo en nat y veras que te sale como digo.

Desconectado

#9 05-10-2018 13:09:20

Patcher
waircut

Registrado: 14-01-2016
Mensajes: 652

Re: kali detecta el adaptador pero no ve las redes

Me cito a mi mismo

si se trata de una tarjeta USB, lo normal es que capture el dipositivo USB desde la máquina virtual

Eso es lo que yo entiendo, con la información que tenemos, que alguien haría "normalmente" por ser lo más obvio y sencillo. Por el momento es premeditado empezar a hablar de configuraciones NATS e historías, almenos hasta que tengamos más información.

Y vuelvo a insistir, por tercera vez, en que antes de desviar mas el hilo hacia derroteros que puede que nada tengan que ver, lo mejor es que ahinoa789 responda a las preguntas que se le formularon en la primera respuesta.

Desconectado

#10 05-10-2018 13:33:28

crash
Expulsado

Registrado: 25-10-2017
Mensajes: 1,049

Re: kali detecta el adaptador pero no ve las redes

virtualbox recién instalado y lo configura directamente como nat. y yo estoy en pc de sobremesa, osea que uso usb si o si.
Captura-de-pantalla_2018-10-05_14-24-59.jpeg

hay que modificar los ajustes para que la reconozca como invitado y no como anfitrión + invitado. (NAT)
después de eso que explique como lo tiene configurado y lo que le sucede en kali, y luego responda a las preguntas que le haceis.

Desconectado

#11 05-10-2018 14:25:49

kcdtv
Administrator

Registrado: 14-11-2014
Mensajes: 5,597

Re: kali detecta el adaptador pero no ve las redes

Por lo que dice  ahinoa789 de momento quedan claramente descartados los problemas de configuración de Maquina Virtual ya que dice haberlo conseguido anteriormente con Sistemas Operativos antiguos. wink
El guion es:
- La interfaz está detectada
- Puesta en modo monitor
- Pero airodump-ng se queda mudo.
Y esto no pasaba con las viejas distribuciones (airodump-ng funcionaba bien)
 
¿Para qué alargar ya este hilo con capturas de pantalla y suposiciones que quedan fuera del guion establecido?
Esto entorpece la lectura del hilo y perdemos el enfoque...
Partimos del principio que la información proporcionada es correcta y nos ubicamos hacia lo relevante: Ver el driver + chipset, las versiones de las cosas, los comandos ejecutados,..
   No interesa ver a ninguna captura de pantalla de momento sino la salida (copiada y pegada, por favor, no con capturas de pantalla) de los comandos de redes-sistemas básicos pertinentes y de la suite aircrack-ng.

Desconectado

#12 05-10-2018 17:47:50

ahinoa789
Usuario

Registrado: 04-10-2018
Mensajes: 5

Re: kali detecta el adaptador pero no ve las redes

Pensé que con las imágenes respondía las preguntas de mejor forma.

Sí, tiene varios años el adaptador pero funciona bien. Tiene una Ralink RT2870. Cuando digo que la detecta perfectamente me refiero a que Kali ve el adaptador y lo pone en modo monitor sin problemas pero luego al escanear no aparecen las redes.

Por las dudas voy a probar con otro que me va a prestar un compañero esta tarde para descartar que ese podría ser el problema. Luego lo pruebo en casa y posteo que pasó. Hasta pronto y gracias!!

Desconectado

#13 05-10-2018 18:31:05

kcdtv
Administrator

Registrado: 14-11-2014
Mensajes: 5,597

Re: kali detecta el adaptador pero no ve las redes

Siempre mejor con salidas de consola. Las imágenes es un rollo: No puedes copiar y pegar el código para probar, buscar en la red.
Si visitas otros sitios de soporte linux verás que te piden la salida en texto bruto cuando pones imágenes.
¡Suerte con la computadora del colega!

Desconectado

#14 08-10-2018 00:02:40

ahinoa789
Usuario

Registrado: 04-10-2018
Mensajes: 5

Re: kali detecta el adaptador pero no ve las redes

He probado usando otro adaptador y el escaneo del airodump se realizó bien. No entiendo porque no funcionó el otro adaptador porque en el Windows esta trabajando bien. Gracias y un saludo cordial,

Ahinoa

Desconectado

#15 08-10-2018 09:17:31

kcdtv
Administrator

Registrado: 14-11-2014
Mensajes: 5,597

Re: kali detecta el adaptador pero no ve las redes

Sin estas salidas de consolas que nos has prometido no te podemos decir nada... Saludos.

Desconectado

#16 16-09-2022 18:17:40

MauroS99
Usuario

Registrado: 16-09-2022
Mensajes: 2

Re: kali detecta el adaptador pero no ve las redes

hola, es un post muy viejo este pero me paso lo mismo, exactamente lo mismo, me detecta mi adaptador(RT3570 Ralink) lei todas sus respuesta pero nada concreto, quizas si tenga q cambiar de adaptador pero mientras lo quiero solucionar, estoy hace mas de un año con el problema, gracias.
Virtual box, esta en Nat y la placa de red por usb

Desconectado

#17 17-09-2022 13:30:25

kcdtv
Administrator

Registrado: 14-11-2014
Mensajes: 5,597

Re: kali detecta el adaptador pero no ve las redes

Bienvenido al foro MauroS99 smile
Seguimos necesitando un copiado-pegado de

lsusb
iw dev
airmon-ng
dmesg | tail -n 50

quizas si tenga q cambiar de adaptador pero mientras lo quiero soluciona

No necesitas cambiar nada, los chipset ralink (ahora mediatek) funcionan
Es problema de configuración.
PD; No sirve de nada pedirme ayuda por mail, responderé de todo modo en el foro

Desconectado

#18 20-09-2022 06:12:07

MauroS99
Usuario

Registrado: 16-09-2022
Mensajes: 2

Re: kali detecta el adaptador pero no ve las redes

perdon, recien empiezo, aqui dejo lo que me tiro la terminal

lsusb:             

Bus 001 Device 007: ID 148f:5370 Ralink Technology, Corp. RT5370 Wireless Adapter
Bus 001 Device 004: ID 80ee:0021 VirtualBox USB Tablet
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

iw dev:        (no mostró nada)

este es un poco largo pero va.
dmesg | tail -n 50:

[  628.379764] usb 1-2: config 1 interface 0 altsetting 0 endpoint 0x81 has invalid maxpacket 512, setting to 64
[  628.379779] usb 1-2: config 1 interface 0 altsetting 0 endpoint 0x1 has invalid maxpacket 512, setting to 64
[  628.379786] usb 1-2: config 1 interface 0 altsetting 0 endpoint 0x2 has invalid maxpacket 512, setting to 64
[  628.379791] usb 1-2: config 1 interface 0 altsetting 0 endpoint 0x3 has invalid maxpacket 512, setting to 64
[  628.379797] usb 1-2: config 1 interface 0 altsetting 0 endpoint 0x4 has invalid maxpacket 512, setting to 64
[  628.379802] usb 1-2: config 1 interface 0 altsetting 0 endpoint 0x5 has invalid maxpacket 512, setting to 64
[  628.379807] usb 1-2: config 1 interface 0 altsetting 0 endpoint 0x6 has invalid maxpacket 512, setting to 64
[  628.624535] usb 1-2: New USB device found, idVendor=148f, idProduct=5370, bcdDevice= 1.01
[  628.624548] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  628.624553] usb 1-2: Product: 802.11 n WLAN
[  628.624558] usb 1-2: Manufacturer: Ralink
[  628.624561] usb 1-2: SerialNumber: 1.0
[  629.199743] usb 1-2: reset full-speed USB device number 6 using ohci-pci
[  630.098729] ieee80211 phy4: rt2x00usb_vendor_request: Error - Vendor Request 0x07 failed for offset 0x1000 with error -110
[  630.098753] ieee80211 phy4: rt2800_probe_rt: Error - Invalid RT chipset 0x0000, rev 0000 detected
[  630.098765] ieee80211 phy4: rt2x00lib_probe_dev: Error - Failed to allocate device
[  630.563855] usb 1-2: reset full-speed USB device number 6 using ohci-pci
[  631.449765] ieee80211 phy5: rt2x00usb_vendor_request: Error - Vendor Request 0x07 failed for offset 0x1000 with error -110
[  631.449790] ieee80211 phy5: rt2800_probe_rt: Error - Invalid RT chipset 0x0000, rev 0000 detected
[  631.449801] ieee80211 phy5: rt2x00lib_probe_dev: Error - Failed to allocate device
[  631.947834] usb 1-2: reset full-speed USB device number 6 using ohci-pci
[  632.834131] ieee80211 phy6: rt2x00usb_vendor_request: Error - Vendor Request 0x07 failed for offset 0x1000 with error -110
[  632.834144] ieee80211 phy6: rt2800_probe_rt: Error - Invalid RT chipset 0x0000, rev 0000 detected
[  632.834149] ieee80211 phy6: rt2x00lib_probe_dev: Error - Failed to allocate device
[  649.765746] usb 1-2: USB disconnect, device number 6
[  665.183803] usb 1-2: new full-speed USB device number 7 using ohci-pci
[  665.884028] usb 1-2: config 1 interface 0 altsetting 0 endpoint 0x81 has invalid maxpacket 512, setting to 64
[  665.884033] usb 1-2: config 1 interface 0 altsetting 0 endpoint 0x1 has invalid maxpacket 512, setting to 64
[  665.884035] usb 1-2: config 1 interface 0 altsetting 0 endpoint 0x2 has invalid maxpacket 512, setting to 64
[  665.884037] usb 1-2: config 1 interface 0 altsetting 0 endpoint 0x3 has invalid maxpacket 512, setting to 64
[  665.884038] usb 1-2: config 1 interface 0 altsetting 0 endpoint 0x4 has invalid maxpacket 512, setting to 64
[  665.884040] usb 1-2: config 1 interface 0 altsetting 0 endpoint 0x5 has invalid maxpacket 512, setting to 64
[  665.884041] usb 1-2: config 1 interface 0 altsetting 0 endpoint 0x6 has invalid maxpacket 512, setting to 64
[  666.131053] usb 1-2: New USB device found, idVendor=148f, idProduct=5370, bcdDevice= 1.01
[  666.131070] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  666.131077] usb 1-2: Product: 802.11 n WLAN
[  666.131084] usb 1-2: Manufacturer: Ralink
[  666.131089] usb 1-2: SerialNumber: 1.0
[  666.707768] usb 1-2: reset full-speed USB device number 7 using ohci-pci
[  667.579429] ieee80211 phy7: rt2x00usb_vendor_request: Error - Vendor Request 0x07 failed for offset 0x1000 with error -110
[  667.579443] ieee80211 phy7: rt2800_probe_rt: Error - Invalid RT chipset 0x0000, rev 0000 detected
[  667.579448] ieee80211 phy7: rt2x00lib_probe_dev: Error - Failed to allocate device
[  668.028206] usb 1-2: reset full-speed USB device number 7 using ohci-pci
[  668.920634] ieee80211 phy8: rt2x00usb_vendor_request: Error - Vendor Request 0x07 failed for offset 0x1000 with error -110
[  668.920656] ieee80211 phy8: rt2800_probe_rt: Error - Invalid RT chipset 0x0000, rev 0000 detected
[  668.920666] ieee80211 phy8: rt2x00lib_probe_dev: Error - Failed to allocate device
[  669.440291] usb 1-2: reset full-speed USB device number 7 using ohci-pci
[  670.332936] ieee80211 phy9: rt2x00usb_vendor_request: Error - Vendor Request 0x07 failed for offset 0x1000 with error -110
[  670.332961] ieee80211 phy9: rt2800_probe_rt: Error - Invalid RT chipset 0x0000, rev 0000 detected
[  670.332972] ieee80211 phy9: rt2x00lib_probe_dev: Error - Failed to allocate device

espero sus respuestas, thnks

Desconectado

#19 20-09-2022 09:26:00

kcdtv
Administrator

Registrado: 14-11-2014
Mensajes: 5,597

Re: kali detecta el adaptador pero no ve las redes

Buenos días biere

  • Podemos ver que tu dispositivo está correctamente detectado "físicamente"

    Bus 001 Device 007: ID 148f:5370 Ralink Technology, Corp. RT5370 Wireless Adapter

    Vemos a su chipset Ralink USB (RTXXXX) y [email protected] sabemos que es compatible (driver rt2800usb)

  • No obstante no está detectado por iw, es decir el software encargado de gestionar las interfaces wifi

    iw dev:        (no mostró nada)

En estos casos (interfaz detectada con lsusb pero no detectada por iw) es generalmente porque faltan los drivers o el firmware. O ambos.
Ejecuta en consola

apt-cache policy firmware-nonfree

O te devolverá una salida detallada o te devolverá un error "unable to locate package" como este:

[email protected]:~$ apt-cache policy noexiste
N: No se ha podido localizar el paquete noexiste

Comenta o pon aquí la salida en consoia.
Si no está instalado hay que instalarlo

  Luego está el tema de la maquina virtual...
Porque en tu log de errores vemos

[  628.624553] usb 1-2: Product: 802.11 n WLAN
[  628.624558] usb 1-2: Manufacturer: Ralink
[  628.624561] usb 1-2: SerialNumber: 1.0
[  629.199743] usb 1-2: reset full-speed USB device number 6 using ohci-pci

El USB 2.0 está "rebajado" a USB 1.0 y esto es probablemente un fallo en la configuración de tu MV.

Root Cause
The Enhanced Host Controller Interface (EHCI) is a register-level interface that enables a host controller for USB or FireWire hardware to communicate with a host controller driver in software.
This error indicates that USB 2.0 may not function on your system, or may function only at USB 1.1 speeds.

Why is the error "kernel: usb 1-2.2: reset high speed USB device using ehci_hcd and address 6" written to the /var/log/messages file?
¿Has instalado Oracle VM Extension Pack ?
¿Has habilitado la compatibilidad USB2,0 en el parámetro USB de tu maquina virtual?

Desconectado

Anuncio

Wifi-libre.com: El libre pensamiento para un internet libre / Regístrese ahora

Temas similares

Tema Respuestas Vistas Ultimo mensaje
5 1206 28-09-2022 14:15:12 por kcdtv
3 285 26-09-2022 12:01:52 por kcdtv
24 3634 22-09-2022 15:23:45 por kcdtv
18 7520 20-09-2022 09:26:00 por kcdtv
Pegado:
520 308243 17-09-2022 13:34:02 por kcdtv

Pie de página

Información del usuario

Ultimo usuario registrado: nikos3194
Usuarios registrados conectados: 0
Invitados conectados: 13

Estadisticas de los foros

Número total de usuarios registrados: 2,364
Número total de temas: 1,600
Número total de mensajes: 15,280

Máx. usuarios conectados: 373 el 30-09-2019 15:04:36